您的位置:

java次方,java次方运算符

本文目录一览:

java中如何表示a的b次方

java中乘方用Math.pow来实现,举例如下:

public

static

void

main(String[]

args)

{

int

a=2;

/*底数*/

int

b=3;

/*乘方*/

double

f=Math.pow(a,b);

/*a和b套用到此行的程式(a的b次方等於f)*/

System.out.println(“2的3次方等於”+f);

}

java中10的n次方怎么表示

java中10的n次方的表示方式:

方法声明:Math.pow(double   m,   double  n)

参数说明:m为要求方的数,n为次方数

当然如果你愿意也可以自己写个方法来实现m的n次方,实现起来也相当简单。

下面是自己写的例子,我觉得用整数做参数就行了,一般都是整数去求方的。

public static long pow(long m, long n){

long result = 1L;        //0次方时为1

for(int=0;in;i++){

result *= m;          //每次乘上次计算次方的结果

}

return result;            //计算好了,返回值

}

如何使用Java计算次方

计算2的N次方

时间限制: 1000ms内存限制: 65536kB

描述

任意给定一个正整数N(N=100),计算2的N次方的值。

输入

输入只有一个正整数N。

输出

输出2的N次方的值。

样例输入

5

样例输出

32

参考代码

[java] view plain copy print?

import java.util.*;

public class Main {

public final static int SIZE = 30;

public static void main(String[] args) throws Exception {

Scanner cin = new Scanner(System.in);

int n = cin.nextInt();

int res[] = new int[SIZE + 1];

int i;

for(i = 0;i SIZE;++ i){

res[i] = 0;

}

res[0] = 1;

while(n 0){

for(i = 0;i SIZE;++ i){

res[i] *= 2;

}

for(i = 0;i SIZE;++ i){

if(res[i] 9){

res[i + 1] += res[i] / 10;

res[i] %= 10;

}

}

n --;

}

boolean bl = false;

StringBuffer bf = new StringBuffer();

for(i = SIZE;i = 0;-- i){

if(res[i] != 0 || bl){

bf.append(res[i]);

bl = true;

}

}

System.out.println(bf);

}

}

根据高位低位改进的代码:

[java] view plain copy print?

/*

* Title :power 2

* From :

* Time :2011-10-11 21:10PM

* Author :Eric Zhou,binfeihan

* Email :binfeihan@126.com

*/

import java.io.BufferedReader;

import java.io.IOException;

import java.io.InputStreamReader;

public class Main {

public static void main(String[] args) throws IOException{

BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));

int n = Integer.parseInt(cin.readLine().trim());

System.out.println(my_power_2(n));

//System.out.println(Long.MAX_VALUE);

//System.out.println(Long.MIN_VALUE);

}

public static StringBuffer my_power_2(int N){

StringBuffer v = new StringBuffer("");

long num[] = new long[2];

num[1] = 1;

if(N 62){

num[0] = 1;

num[0] = num[0](N - 62);

num[1] = num[1]62;

String s = String.valueOf(num[1]);

int size = 30,i = 0,j = 0;

long n[] = new long[size + 1];

//System.out.println(num[0]+" "+s);

for(i = s.length() - 1;i = 0;-- i){

n[j ++] = (long) (num[0] * (s.charAt(i) - '0'));

//System.out.println(n[j - 1]);

}

for(i = 0;i size;++ i){

while(n[i] 9){

n[i + 1] += n[i] / 10;

n[i] %= 10;

}

}

boolean bl = false;

for(i = size;i = 0;-- i){

if(n[i] != 0 || bl){

v.append(n[i]);

bl = true;

}

}

}else{

num[1] = num[1] N;

v.append(String.valueOf(num[1]));

}

return v;

}

}

JAVA中算式的次方怎样表达

不能直接写的

只能 Q*Q*Q(Q的3次方)

或者你自己写个方法

public class MyMath{

public static int Math(int a,int j){

int b=1;

for(int i = 0;i j; i++){

b=b*a;

}

if(a==0j==0) return 1;

else return b;

}

}